Why am I getting this server error when using the API to upload builds?

Posted in General by Tamas E Tue Feb 23 2016 00:45:01 GMT+0000 (UTC)·5·Viewed 999 times

Here is the error ``` <!DOCTYPE html> <html> <head> <meta name="viewport" content="width=device-width, initial-scale=1"> <style type="text/css"> html, body, iframe { margin: 0; padding: 0; height: 100%; } iframe { display: block; width: 100%; border: none; } </style> <title>Application Error</title> </head> <body> <iframe src="https://s3.amazonaws.com/apphub-resources/404.html"> <p>Application Error</p> </iframe> </body> </html> ``` Here is my call: ``` curl -X PUT \ -H "X-AppHub-Application-ID: ${app_id}" \ -H "X-AppHub-Application-Secret: ${app_secret}" \ -H "Content-Type: application/zip" \ -L https://api.apphub.io/v1/upload \ --upload-file builds/${current_time}build.zip ``` Thanks
Matt Arbesfeld
Mar 8, 2016

Hi Tamas, I'm not sure that I have seen this error before. Would you mind sharing how you created this build?

Tamas E
Mar 8, 2016

I build using the CLI.

node_modules/.bin/apphub build -o builds/${current_time}build.zip

If I upload the build manually, it works fine

Richard Gill
Apr 11, 2016

I also have this problem too.

Matt Arbesfeld
Apr 12, 2016

We have seen this error come up in the past. Could you folks try out AppHub Deploy: https://github.com/joshuapinter/apphubdeploy and let us know if you still have the issue with the CLI?

Richard Gill
Apr 12, 2016

Thanks Matt. This seems to work reliably for me. I've stuck a couple issues and a PR in that repo (it doesn't work on linux for my circleci build). But other than that - all good.

  
Markdown is allowed